Bug 3567 - Documentation for pam_slurm_adopt
Summary: Documentation for pam_slurm_adopt
Status: RESOLVED FIXED
Alias: None
Product: Slurm
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 17.02.1
Hardware: Linux Linux
: --- 4 - Minor Issue
Assignee: Marshall Garey
QA Contact:
URL:
: 4218 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-10 10:35 MST by Tim Wickberg
Modified: 2018-03-27 15:04 MDT (History)
3 users (show)

See Also:
Site: SchedMD
Alineos Sites: ---
Bull/Atos Sites: ---
Confidential Site: ---
Cray Sites: ---
HPCnow Sites: ---
HPE Sites: ---
IBM Sites: ---
NOAA SIte: ---
OCF Sites: ---
SFW Sites: ---
SNIC sites: ---
Linux Distro: ---
Machine Name:
CLE Version:
Version Fixed: 17.11.6 18.08.0-pre2
Target Release: ---
DevPrio: ---


Attachments
patch (8.83 KB, patch)
2017-09-20 11:01 MDT, Marshall Garey
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Wickberg 2017-03-10 10:35:30 MST
pam_slurm_adopt is cool, and AFAIK a unique capability for us. But we have *zero* documentation on the website for it - the only thing we ship is a README file in the source directory.

Can you make a page under doc/html page describing the setup and common configuration? You can steal the contents of that README almost verbatim, although I'd avoid mentioning some of the less-sane options it theoretically supports. (E.g., it mentions an argument meant to force root to be subject to the same restriction - but no one should ever use that, and the code itself intentionally refuses to enforce that option.)

You'll probably want to test this on the knc node - there are some installation quirks you'll want to document with RHEL7 (which most people would use it on), and you'd want to explicitly reference which config files to edit. (The most important thing is to disable pam_systemd, which will totally ruin everything forever if left enabled.)
Comment 7 Felip Moll 2017-10-04 02:57:55 MDT
*** Bug 4218 has been marked as a duplicate of this bug. ***
Comment 12 Marshall Garey 2017-12-12 22:13:46 MST
Documentation is live on the website.

Closing as resolved/fixed.
Comment 13 Marshall Garey 2017-12-12 22:19:53 MST
Actually, the FAQ needs to be fixed for question 9 under the "For Administrators" section. The update was confusing because it says "the rest is about pam_slurm" but doesn't actually talk about pam_slurm until the last paragraph.

Reopening.
Comment 18 Tim Wickberg 2018-03-27 15:04:05 MDT
Thanks Marshall. Committed, and tagging this as closed.

commit b882c2c8f11e28a31350f03659731c3906aa70fd
Author: Marshall Garey <marshall@schedmd.com>
Date:   Tue Mar 27 15:02:31 2018 -0600

    Docs - update FAQ entry about use of PAM.
    
    Bug 3567.