Bug 4510 - PrologFlags=SendGIDs: invalid option
Summary: PrologFlags=SendGIDs: invalid option
Status: RESOLVED DUPLICATE of bug 4412
Alias: None
Product: Slurm
Classification: Unclassified
Component: slurmctld (show other bugs)
Version: 17.11.0
Hardware: Linux Linux
: --- 2 - High Impact
Assignee: Tim Wickberg
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2017-12-12 21:49 MST by Kilian Cavalotti
Modified: 2017-12-13 13:30 MST (History)
0 users

See Also:
Site: Stanford
Alineos Sites: ---
Bull/Atos Sites: ---
Confidential Site: ---
Cray Sites: ---
HPCnow Sites: ---
HPE Sites: ---
IBM Sites: ---
NOAA SIte: ---
OCF Sites: ---
SFW Sites: ---
SNIC sites: ---
Linux Distro: ---
Machine Name:
CLE Version:
Version Fixed:
Target Release: ---
DevPrio: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kilian Cavalotti 2017-12-12 21:49:48 MST
Hi!

The PrologFlags=SendGIDs option announced in
https://github.com/SchedMD/slurm/commit/c83d22e7160a8982da6f22882155e6fbc7fa1fde doesn't work:

# grep PrologFlags /etc/slurm/slurm.conf
PrologFlags=SendGIDs
# slurmctld -Dvvv
slurmctld: error: Invalid PrologFlag: SendGIDs
slurmctld: fatal: PrologFlags invalid: SendGIDs
# rpm -q slurm-slurmctld
slurm-slurmctld-17.11.0-1.el7.centos.x86_64

That's not great... :\


From looking at https://bugs.schedmd.com/show_bug.cgi?id=4412, I kind of understand that this is required if UsePAM=1, am I correct? Because otherwise, with UsePAM=1, jobs immediately fail with 
"error: pam_open_session: Cannot make/remove an entry for the specified session"


What's the correct way of using PAM with Slurm 17.11? 
What is the correct option to centralize GID lookups on the controller?

Thanks,
-- 
Kilian
Comment 1 Tim Wickberg 2017-12-12 22:18:07 MST
You'll need to use LaunchParameters=send_gids for now; I should have the final fix for bug 4412 pushed next week.

Marking resolved as a duplicate of bug 4412.

*** This bug has been marked as a duplicate of bug 4412 ***
Comment 2 Kilian Cavalotti 2017-12-13 12:04:06 MST
All right, thanks for the info, we'll use LaunchParameters=send_gids for now.

Will that parameter still be needed once PrologFlags=SendGIDs lands?
Comment 3 Tim Wickberg 2017-12-13 13:30:16 MST
That is the final config option for that functionality; the implementation changed to not longer depend on the prolog to work properly.