Bug 8272 - RPMs do not create the /var/log/slurm directory
Summary: RPMs do not create the /var/log/slurm directory
Status: RESOLVED INFOGIVEN
Alias: None
Product: Slurm
Classification: Unclassified
Component: Build System and Packaging (show other bugs)
Version: 19.05.5
Hardware: Linux Linux
: --- 4 - Minor Issue
Assignee: Jason Booth
QA Contact:
URL:
Depends on:
Blocks:
 
Reported: 2019-12-26 03:28 MST by Ole.H.Nielsen@fysik.dtu.dk
Modified: 2019-12-26 10:56 MST (History)
0 users

See Also:
Site: DTU Physics
Alineos Sites: ---
Bull/Atos Sites: ---
Confidential Site: ---
Cray Sites: ---
HPCnow Sites: ---
HPE Sites: ---
IBM Sites: ---
NOAA SIte: ---
OCF Sites: ---
SFW Sites: ---
SNIC sites: ---
Linux Distro: ---
Machine Name:
CLE Version:
Version Fixed:
Target Release: ---
DevPrio: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ole.H.Nielsen@fysik.dtu.dk 2019-12-26 03:28:16 MST
I'm testing a new compute node installation method using Ansible, and I have discovered that the Slurm 19.05 RPMs do not create the /var/log/slurm directory, which my previous installation scripts had created manually.  With this omission Slurm creates no log files at all which is quite bad.

IMHO, the slurm-xx.xx RPM must create the /var/log/slurm directory so that users won't have to do this manually.  Probably a configuration in the %post section in slurm.spec is required with:

mkdir /var/log/slurm
chown slurm: /var/log/slurm

FYI: My compute node has these RPMs installed:

$ rpm -qa | grep slurm
slurm-19.05.5-1.el7.x86_64
slurm-slurmd-19.05.5-1.el7.x86_64
slurm-perlapi-19.05.5-1.el7.x86_64
slurm-devel-19.05.5-1.el7.x86_64
slurm-pam_slurm-19.05.5-1.el7.x86_64
slurm-contribs-19.05.5-1.el7.x86_64
Comment 2 Jason Booth 2019-12-26 10:44:42 MST
This is the intended behavior since the default is to log via syslog and then allow sites to specify the logging directory/file via the SlurmdLogFile. Additionally, not all sites use /var/log/slurm so hardcoding this would be less than desirable.

SlurmdLogFile
Fully qualified pathname of a file into which the slurmd daemon's logs are written. The default value is none (performs logging via syslog). Any "%h" within the name is replaced with the hostname on which the slurmd is running. Any "%n" within the name is replaced with the Slurm node name on which the slurmd is running.
See the section LOGGING if a pathname is specified.


I am making this as resolved.
Comment 3 Ole.H.Nielsen@fysik.dtu.dk 2019-12-26 10:56:32 MST
(In reply to Jason Booth from comment #2)
> This is the intended behavior since the default is to log via syslog and
> then allow sites to specify the logging directory/file via the
> SlurmdLogFile. Additionally, not all sites use /var/log/slurm so hardcoding
> this would be less than desirable.
> 
> SlurmdLogFile
> Fully qualified pathname of a file into which the slurmd daemon's logs are
> written. The default value is none (performs logging via syslog). Any "%h"
> within the name is replaced with the hostname on which the slurmd is
> running. Any "%n" within the name is replaced with the Slurm node name on
> which the slurmd is running.
> See the section LOGGING if a pathname is specified.
> 
> 
> I am making this as resolved.

Hi Jason, thanks for the quick answer!
Ole